Tuesday, December 11, 2012

BizTalk Gotchas that got me

Hereby some BizTalk gotchas, that got me, it’s a small compilation as I’m trying to group related subjects together, in future posts I’ll focus on MSMQ, ESB Toolkit and other stuff.

Issue: Outputfile name is %sourcefilename%

Is it, that…? You have promoted the FILE.ReceivedFileName and configured the macro %SourceFileName%, however, this is CASE SENSITIVE!

Issue: No processing takes place after a BRE call

Is it, that…? You might be using a .Net helperclass, you’ve added the ‘StaticSupport’ following (http://msdn.microsoft.com/en-us/library/dd298814(v=bts.10).aspx). This won’t work…the StaticSupport should be created under the WOW64Node

Issue: Pipeline configuration change does not have any effect

Is it, that…? You are using a dynamic send port…if so, stop/start the application-port

Issue: Inside my orchestration, a variable assignments (from context properties) leads to an exception (missing property exception)

Is it, that…? You are not assigning the variable from the message property in the very beginning of the orchestration, you are doing this when you need the variable as you would do in normal code….if possible, make sure that you minimize the number of shapes between receive and message context properties retrievals.

Issue: You are using the Date functoid to generate a date, you want to use a different format (From the functoid: The output format is CCYY-MM-DDThh:mm:ss.)

Is it, that…? You are using a ConvertDate functoid from a library that requires an input format, the description from the Date functoid does not work..

This is because the description is not correct and should be as defined in Input[1]

clip_image002

In my case I used a functoid library which has a parseExact call;

clip_image002[4]

Issue: I’m migrating a solution that contains a service reference and want to update this reference with a new URL / or use a classic ASP.Net webservice

Is it, that…? You forgot that little trick, which allows you to create/update the reference for classic 2.0 references Glimlach

clip_image002[6]

Click Advanced

clip_image004

Click ‘Add Reference’

clip_image006

Enter the address

clip_image007

Issue: Debugging XSLT raises an error

Is it, that…? You are calling a custom functoid / .Net class in the map…you won’t be able to debug

Issue: Calling an functoid / .Net class in an XSLT map does not work

Is it, that…? Only when you have an external XSLT it is possible to call a functoid / .Net class from the XSLT

Issue: There is no tracking data

Is it, that…? There are multiple tracking hosts

 

I’ll follow up with gotchas related to the ESB Toolkit.

 

Cheers,

Sander